Displaying 1 to 7 from 7 results

please-upgrade-node - :information_desk_person: Show a message to your users to upgrade Node instead of a stacktrace

  •    Javascript

It's common for new Node users to miss the npm engines warning when installing a CLI. This package displays a beginner-friendly message if their Node version is below the one expected.>= is the only operator supported by please-upgrade-node (e.g. >=4, >=4.0, >=4.0.0).




templates - System for creating and managing view collections, rendering, engines, routes and more

  •    Javascript

System for creating and managing template collections, and rendering templates with any node.js template engine. Can be used as the basis for creating a static site generator or blog framework. This section describes API features that are shared by all Templates classes.

layouts - Wraps templates with layouts

  •    Javascript

Wraps templates with layouts. Layouts can use other layouts and be nested to any depth. This can be used 100% standalone to wrap any kind of file with banners, headers or footer content. Use for markdown, HTML, handlebars views, lo-dash templates, etc. Layouts can also be vinyl files. Please consider following this project's author, Brian Woodward, and consider starring the project to show your ❤️ and support.