gulp-phpcs - Gulp plugin for running PHP Code Sniffer

  •        66

Gulp plugin for running PHP Code Sniffer. Choose correct version of gulp-phpcs. One should use gulp-phpcs@1.x for PHPCS 2.x and gulp-phpcs@2.x with PHPCS 3.x.

https://github.com/JustBlackBird/gulp-phpcs

Dependencies:

gulp-util : ^3.0.7
through2 : ^2.0.0
chalk : ^1.1.1
pluralize : ^1.2.1
which : ^1.2.7

Tags
Implementation
License
Platform

   




Related Projects

gulp-responsive - gulp-responsive generates images at different sizes

  •    Javascript

gulp-responsive depends on sharp. Sharp is one of the fastest Node.js modules for resizing JPEG, PNG, WebP and TIFF images. If you are using Mac OS then before installing gulp-responsive you should install the libvips library. Further information and instructions can be found in the sharp installation guide.

gulp-bump - Bump any version in any file which supports semver with gulp (gulpjs.com)

  •    Javascript

gulp-bump v2 supports Any valid semver in any filetype. ####You can view more examples in the example folder.

gulp-rev-replace - Rewrite occurences of filenames which have been renamed by gulp-rev

  •    Javascript

Pipe through a stream which has both the files you want to be updated, as well as the files which have been renamed. For example, we can use gulp-useref to concatenate assets in an index.html, and then use gulp-rev and gulp-rev-replace to cache-bust them.

gulp-sass - SASS plugin for gulp

  •    Javascript

Sass plugin for Gulp. Before filing an issue, please make sure you have Updated to the latest Gulp Sass and have gone through our Common Issues and Their Fixes section.


gulp-clean-css - Minify css with clean-css.

  •    Javascript

This is just a simple gulp plugin, which means it's nothing more than a thin wrapper around clean-css. If it looks like you are having CSS related issues, please contact clean-css. Only create a new issue if it looks like you're having a problem with the plugin itself. See the CleanCSS options.

gulp-rename - Rename files easily

  •    Javascript

gulp-rename is a gulp plugin to rename files easily. gulp-rename provides simple file renaming methods.

gulp-if - Conditionally run a task

  •    Javascript

A ternary gulp plugin: conditionally control the flow of vinyl objects. Note: Badly behaved plugins can often get worse when used with gulp-if. Typically the fix is not in gulp-if.

gulp-typescript - A TypeScript compiler for gulp with incremental compilation support.

  •    Javascript

A gulp plugin for handling TypeScript compilation workflow. The plugin exposes TypeScript's compiler options to gulp using TypeScript API. Updating from version 2? See the breaking changes in version 3.

sublime-phpcs

  •    Python

PHP CodeSniffer, PHP Coding Standard Fixer, Linter and Mess Detector Support for Sublime Text

phpcs-psr - A PHP_CodeSniffer sniff to check against the PSR-0, PSR-1 and PSR-2

  •    PHP

A PHP_CodeSniffer sniff to check against the PSR-0, PSR-1 and PSR-2

PHP_CodeSniffer - PHP_CodeSniffer tokenizes PHP, JavaScript and CSS files and detects violations of a defined set of coding standards

  •    PHP

PHP_CodeSniffer is a set of two PHP scripts; the main phpcs script that tokenizes PHP, JavaScript and CSS files to detect violations of a defined coding standard, and a second phpcbf script to automatically correct coding standard violations. PHP_CodeSniffer is an essential development tool that ensures your code remains clean and consistent. PHP_CodeSniffer requires PHP version 5.4.0 or greater, although individual sniffs may have additional requirements such as external applications and scripts. See the Configuration Options manual page for a list of these requirements.

PHPCompatibility - PHP Compatibility check for PHP_CodeSniffer

  •    PHP

This is a set of sniffs for PHP CodeSniffer that checks for PHP cross-version compatibility. It will allow you to analyse your code for compatibility with higher and lower versions of PHP. The project aims to cover all PHP compatibility changes introduced since PHP 5.0 up to the latest PHP release. This is an ongoing process and coverage is not yet 100% (if, indeed, it ever could be). Progress is tracked on our Github issue tracker.

gulp-babel - Gulp plugin for Babel

  •    Javascript

Issues with the output should be reported on the Babel issue tracker.See the Babel options, except for sourceMap and filename which is handled for you.

gulp-postcss - Pipe CSS through PostCSS processors with a single parse

  •    Javascript

PostCSS gulp plugin to pipe CSS through several plugins, but parse CSS only once.Install required postcss plugins separately. E.g. for autoprefixer, you need to install autoprefixer package.

gulp-replace - A string replace plugin for gulp

  •    Javascript

gulp-replace can be called with a string or regex. The string to search for.